To see historical uptime for Canvas and other services for a specific instance, click here.

Emergency media server maintenance
Incident Report for Instructure
Resolved
The maintenance has been completed and the media tools have returned to normal performance. Thank you for your patience while our team performed this emergency maintenance.
Posted Mar 20, 2020 - 11:02 MDT
Monitoring
The maintenance should now be concluded. The video playback and upload should resume as normal. We will continue to monitor the fix to ensure that it's working as intended.
Posted Mar 20, 2020 - 10:38 MDT
Identified
Our team is performing emergency maintenance to fix errors that were being received when previewing and uploading some videos. During this time, you may continue to see errors and slow upload times when trying to upload a video to Canvas.
Posted Mar 20, 2020 - 10:23 MDT
This incident affected: Canvas (— Media tools).