To view uptime history for your instance of Canvas, click here.

Profile Pictures
Incident Report for Instructure
Resolved
This has been fixed, we apologize for the mix up.
Posted Sep 13, 2017 - 16:11 MDT
Identified
We have identified the cause of mixed up profile pictures and are working to correct them. We will provide updates as they become available.
Posted Sep 13, 2017 - 16:06 MDT