To view uptime history for your instance of Canvas, click here.

Degraded performance in Canvas
Incident Report for Instructure
Resolved
The slowness issues have been resolved, and users should once again be seeing normal levels of performance when using Canvas.
Posted Feb 06, 2017 - 09:16 MST
Monitoring
Our engineers have identified some issues related to the degraded performance in Canvas. Performance appears to be improving, but we will continue to monitor the situation. We once again sincerely apologize for any inconvenience experienced by your users.
Posted Feb 06, 2017 - 08:51 MST
Investigating
A small group of Canvas users are experiencing degraded performance, including slowness and intermittent time out errors. Our engineers are aware of the issue and are working towards a solution. We apologize for any inconvenience experienced by your students and teachers while this is being investigated.
Posted Feb 06, 2017 - 08:09 MST