To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times and even page errors
Incident Report for Instructure
Resolved
There doesn't appear to be any further performance issues with Canvas. We appreciate your patience and sincerely apologize for any inconvenience this may have caused.
Posted Feb 05, 2019 - 10:46 MST
Monitoring
Load times for Canvas users have improved back to expected levels. We are monitoring to ensure there's not further occurrences.
Posted Feb 05, 2019 - 10:18 MST
Identified
Our engineers have identified a potential cause of the long load times some Canvas users are experiencing. We are currently working on a resolution plan and will post another update shortly. Thank you again for your patience.
Posted Feb 05, 2019 - 09:58 MST
Investigating
We are seeing an increase in Canvas load times for some users and some intermittent page errors as well. Our engineering team is currently investigating the cause, and we'll post another update shortly. We appreciate your patience and apologize for this situation.
Posted Feb 05, 2019 - 09:44 MST
This incident affected: Canvas (Canvas LMS).