To view uptime history for your instance of Canvas, click here.

Extended queued time for jobs in the U.S.
Incident Report for Instructure
Resolved
Our queues for job requests in Canvas are back to normal levels. Job requests (such as SIS imports and content migrations) will start processing soon after they are queued. We appreciate your patience as we worked through the large number of job requests this morning, and apologize for any trouble caused by the additional wait times.
Posted Dec 11, 2017 - 15:13 MST
Monitoring
Users in the U.S. are seeing wait times up to 5 minutes for job requests in Canvas such as SIS imports, content migrations, and notifications. Components that process these requests are working normally, but the queue is very high. It may take some time for your job requests to start processing, at which point they will run as normal. Thanks for your patience!
Posted Dec 11, 2017 - 11:26 MST