To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted May 11, 2021 - 12:27 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2021 - 12:20 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2021 - 12:17 MDT
This incident affected: Canvas (Canvas).