To view uptime history for your instance of Canvas, click here.

Beta and Test unavailable
Incident Report for Instructure
Resolved
Our DevOps team has addressed the issue that was affecting Canvas Beta and Test environments, and they are running normally once again.
Posted Jun 26, 2017 - 09:05 MDT
Investigating
Our Beta and Test environment within Canvas is currently down. Our DevOps team is working to resolve this issue as quickly as possible. Thank you for your patience in this matter.
Posted Jun 26, 2017 - 07:27 MDT