To view uptime history for your instance of Canvas, click here.

Some users are unable to access Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 14:43 MDT
Monitoring
A fix has been implemented, we are monitoring the results.
Posted Apr 28, 2021 - 14:35 MDT
Investigating
We are currently investigating this issue.
Posted Apr 28, 2021 - 14:26 MDT
This incident affected: Canvas (Canvas).