To view uptime history for your instance of Canvas, click here.

A small amount of users maybe experiencing error messages or long load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 03, 2020 - 17:36 MDT
Update
We are continuing to work on a fix for the issue.
Posted Sep 03, 2020 - 17:19 MDT
Identified
The issue has been identified and we are working to rectify it.
Posted Sep 03, 2020 - 16:45 MDT
Investigating
We are currently investigating this issue
Posted Sep 03, 2020 - 16:27 MDT
This incident affected: Canvas (Canvas).