To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 05:17 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2020 - 05:12 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 09, 2020 - 05:11 MST
Investigating
We are currently investigating this issue.
Posted Nov 09, 2020 - 05:08 MST
This incident affected: Canvas (Canvas).