To view uptime history for your instance of Canvas, click here.

Discussion and Assignment changes are failing for some users
Incident Report for Instructure
Resolved
We've monitored the issue, and Canvas is now operating at normal capacity. Thank you again for your patience.
Posted Jun 21, 2018 - 20:21 MDT
Monitoring
Our Engineers were able to deploy a fix, resolving those errors. We will continue to monitor this issue, and provide an update soon.
Posted Jun 21, 2018 - 20:06 MDT
Update
While the fix was able to resolve a majority of the errors, some users are still seeing errors when creating, editing, or publishing graded content. Our Engineers are looking into this, and will provide an update soon.
Posted Jun 21, 2018 - 19:50 MDT
Identified
Our Engineers were able to identify the cause of the error, and have implemented a fix. We will continue to monitor this issue, and provide an update in a few minutes.
Posted Jun 21, 2018 - 19:32 MDT
Update
Investigating this further, it appears that updating any graded quiz, graded discussion, or assignment are saving any changes. Our Engineers are still investigating the root cause, and will provide another update soon.
Posted Jun 21, 2018 - 19:15 MDT
Investigating
Some instructors and admins are experiencing errors when attempting to make changes to Discussion and Assignment objects in Canvas. Our Engineers are investigating this behavior, and we'll provide an update soon.
Posted Jun 21, 2018 - 18:51 MDT
This incident affected: Canvas (Canvas LMS).