To view uptime history for your instance of Canvas, click here.

Some North American Users Experiencing Slowness
Incident Report for Instructure
Resolved
Hotfix deployed, issue resolved.
Posted Dec 01, 2017 - 16:51 MST
Monitoring
Slowness seems to have subsided at this point. Still monitoring traffic to verify if the issue has fully resolved.
Posted Dec 01, 2017 - 11:22 MST
Investigating
Some users located in North America are experiencing some slowness in the page load times when accessing Canvas. Our DevOps team is aware of the issue and currently investigating.
Posted Dec 01, 2017 - 10:50 MST