Some Canvas users in the US experiencing Slowness
Incident Report for Canvas
Resolved
Resolved - From 9:01 A.M MDT to 9:14 A.M MDT, some users in the US experienced slowness. Our DevOps team identified and resolved the page load times for affected users. We apologize for any inconvenience.
Posted 10 months ago. Mar 23, 2018 - 09:40 MDT
Investigating
We are aware of slowness affecting a small portion of users in the US Central area. We apologize for the disruption to service and our Devops team are working on resolving the page load times.
Posted 10 months ago. Mar 23, 2018 - 09:25 MDT