To view uptime history for your instance of Canvas, click here.

Some users may be experiencing slowness when accessing Canvas
Incident Report for Instructure
Resolved
Our DevOps team identified and resolved the cause of the slowness. The issue has been resolved. Thank you again for your patience.
Posted Feb 01, 2018 - 22:44 MST
Identified
Our DevOps team has isolated the cause of the issue and is working on a resolution. Again, we apologize for any inconvenience this has caused your users, and we appreciate your patience.
Posted Feb 01, 2018 - 21:40 MST
Investigating
Some users may be experiencing longer load times and page errors when attempting to access Canvas. Our DevOps team is aware and currently working on getting this resolves as soon as possible. We apologize for any inconvenience this may be causing you and will provide an update as soon as it becomes available.
Posted Feb 01, 2018 - 21:04 MST