To view uptime history for your instance of Canvas, click here.

Some users are experiencing issues with MasteryConnect
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 12:05 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2021 - 08:26 MDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2021 - 06:58 MDT