To view uptime history for your instance of Canvas, click here.

Users are experiencing slowness or timeouts when accessing Canvas
Incident Report for Instructure
Resolved
The issue has been resolved. Thank you again for your patience.
Posted Jan 31, 2018 - 22:01 MST
Monitoring
Some Canvas users were experiencing longer load times than expected between 8:36 pm MST and 9:01 pm MST. Our DevOps team has invested the cause and are currently working on implementing a solution. We apologize for any inconvenience this may have caused you and will continue to monitor the situation.
Posted Jan 31, 2018 - 21:18 MST