To view uptime history for your instance of Canvas, click here.

Canvas Page Errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 18, 2022 - 09:44 MDT
Investigating
Some users may receive page errors while accessing Canvas content.
Posted Apr 18, 2022 - 09:39 MDT
This incident affected: Canvas (Canvas).