To view uptime history for your instance of Canvas, click here.

Some Australian Canvas users are experiencing slow load times and timeouts.
Incident Report for Instructure
Resolved
Our DevOps team was able to isolate and resolve the cause of the issue. Thank you for your patience, we apologize for any inconvenience this may have caused your users.
Posted May 04, 2018 - 15:58 MDT
Investigating
We are aware of slow load times and page timeouts affecting a small portion of Australian-based users. Our DevOps team is working on resolving this issue. We apologize for any disruption experienced by your users.
Posted May 04, 2018 - 15:33 MDT