To view uptime history for your instance of Canvas, click here.

Some Canvas users are experiencing long load times while accessing Canvas
Incident Report for Instructure
Resolved
Users are no longer experiencing long load times. Service has been restored. Thank you all for your patience.
Posted Dec 11, 2018 - 15:45 MST
Update
Our DevOps team is continuing to monitor this situation, we'll provide an update in a few minutes.
Posted Dec 11, 2018 - 15:28 MST
Monitoring
Our DevOps team was able to identify the cause and apply a fix, and it appears that users are experiencing normal load times. We'll continue to monitor the situation and provide and update in a few minutes.
Posted Dec 11, 2018 - 15:10 MST
Investigating
Some Canvas users are seeing long load times while trying to access Canvas. We're currently investigating these issues and will post an update shortly. We sincerely apologize for the inconvenience and appreciate your patience.
Posted Dec 11, 2018 - 14:55 MST
This incident affected: Canvas (Canvas LMS).