To view uptime history for your instance of Canvas, click here.

Canvas users in Europe may be experiencing Slow Page load times and page time outs
Incident Report for Instructure
Resolved
Our DevOps team has resolved the Slow page load issue and Canvas is performing normally. Thank you for your patience and we apologize for any inconvenience.
Posted Mar 01, 2018 - 03:12 MST
Investigating
We are aware of slow page load times and page time outs effecting users in Europe. We are working to identify the issue and we will update shortly.
Posted Mar 01, 2018 - 02:50 MST