To view uptime history for your instance of Canvas, click here.

Some US based Canvas users are experiencing long load times while accessing Canvas
Incident Report for Instructure
Resolved
Users are no longer experiencing long load times. Service has been restored. Thank you all for your patience.
Posted Oct 25, 2018 - 15:57 MDT
Monitoring
Our DevOps team was able to deploy a fix, and it appears that users are experiencing normal load times. We'll continue to monitor the situation and provide and update in a few minutes.
Posted Oct 25, 2018 - 15:38 MDT
Identified
Our DevOps team has identified the cause of the issue, and are working towards a solution. We apologize for any inconvenience caused.
Posted Oct 25, 2018 - 15:30 MDT
Update
Our DevOps team is continuing to investigate the cause of this behavior. We apologize for any inconvenience caused.
Posted Oct 25, 2018 - 15:17 MDT
Investigating
Some Canvas users are seeing long load times while trying to access Canvas. We're currently investigating these issues and will post an update shortly. We sincerely apologize for the inconvenience and appreciate your patience.
Posted Oct 25, 2018 - 14:47 MDT
This incident affected: Canvas (Canvas LMS).