Some Canvas users in the US experiencing slow load times
Incident Report for Canvas
Resolved
Our DevOps team was able to isolate the cause and resolve the issue. Thank you for your patience and we apologize for any inconvenience this may have caused your users.
Posted 3 months ago. May 03, 2018 - 13:43 MDT
Investigating
We are aware of slow load times affecting a small portion of US-based users. Our DevOps team is working on resolving this issue. We apologize for any disruption experienced by your users.
Posted 3 months ago. May 03, 2018 - 13:22 MDT