To view uptime history for your instance of Canvas, click here.

Some users in US region are seeing slow page load times
Incident Report for Instructure
Resolved
Our DevOps team has deployed a fix for the issue. Normal Canvas load times should resume.
Posted Jan 23, 2019 - 09:01 MST
Identified
Our Devops team is currently rolling out a fix, and a majority of users are able to access Canvas as expected.
Posted Jan 23, 2019 - 08:20 MST
Update
Our DevOps team is continuing to investigate this issue. We will update as more information becomes available.
Posted Jan 23, 2019 - 07:47 MST
Investigating
We are aware of some users in the US seeing slow load times when accessing Canvas. Our Devops team is looking into what is causing the issue. We will update as more information becomes available.
Posted Jan 23, 2019 - 07:29 MST
This incident affected: Canvas (Canvas LMS).