To view uptime history for your instance of Canvas, click here.

Some users seeing errors when downloading files in the US region
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 11:35 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2020 - 11:21 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 25, 2020 - 11:10 MDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 25, 2020 - 10:55 MDT
Identified
Our Devops team have identified the issue, and are currently working to resolve it. We'll provide another update in a few minutes.
Posted Aug 25, 2020 - 10:39 MDT
Investigating
Some users seeing errors when downloading files in the US region. Our DevOps team is currently working to resolve the issue, and we'll provide an update for that shortly.
Posted Aug 25, 2020 - 10:23 MDT
This incident affected: Canvas (Canvas LMS).