To view uptime history for your instance of Canvas, click here.

Some users are experiencing longer than normal load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 09:56 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 09:45 MST
Investigating
We are currently investigating this issue.
Posted Mar 01, 2021 - 09:22 MST
This incident affected: Canvas (Canvas LMS).