To view uptime history for your instance of Canvas, click here.

A small subset of users are seeing long load times or page timeouts when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 21, 2020 - 10:05 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2020 - 09:51 MDT
Investigating
A small subset of users are seeing long load times or page timeouts when accessing Canvas. Our DevOps team are currently investigating the issue, we'll provide an update shortly.
Posted Aug 21, 2020 - 09:47 MDT
This incident affected: Canvas (Canvas LMS).