To view uptime history for your instance of Canvas, click here.

Some US based users are seeing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
Users are no longer seeing any issues with slowness. We will continue to monitor for any further issues. We appreciate your patience with this situation.
Posted Jan 25, 2019 - 14:30 MST
Investigating
We are currently looking into what is cause long load time for users in Canvas. We will continue to update you when more information becomes available.
Posted Jan 25, 2019 - 09:26 MST
This incident affected: Canvas (Canvas LMS).