To view uptime history for your instance of Canvas, click here.

Starting at 9:01 A.M. MDT, Canvas users in the US may be experiencing slowness
Incident Report for Instructure
Resolved
From 9:01 A.M MDT to 9:14 A.M MDT, some users in the US experienced slowness. Our DevOps team identified and resolved the page load times for affected users. We apologize for any inconvenience.
Posted Mar 15, 2018 - 09:26 MDT
Identified
We are aware of slowness affecting a small portion of users in the US Central area. We apologize for the disruption to service. Our Devops team is working to resolve the page load times.
Posted Mar 15, 2018 - 09:16 MDT