To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
The issue has been resolved, and Canvas is loading normally once again. Thank you so much for your patience.
Posted Aug 07, 2019 - 08:48 MDT
Identified
Some Canvas users are sporadically experiencing longer loading times when accessing Canvas. Our Devops team has been made aware and are currently investigating this behavior. We'll be posting an additional update shortly.
Posted Aug 07, 2019 - 08:36 MDT
This incident affected: Canvas (Canvas LMS).