To view uptime history for your instance of Canvas, click here.

Canvas Support Unavailable due to Internet Outage.
Incident Report for Instructure
Resolved
Our Engineers have successfully restored internet service to the Support office. Chats, Calls and Emails are once again operational. Thank you again for your patience with this matter.
Posted Nov 05, 2017 - 03:27 MST
Investigating
Our Support Office is experiencing an internet outage at present and is unable to take calls, chats or respond to emails. Our engineers are actively working to resolve this issue. Thank you for your patience in this matter.
Posted Nov 05, 2017 - 03:16 MST