To see historical uptime for Canvas and other services for a specific instance, click here.

Canvas Phones System
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Dec 24, 2019 - 14:53 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2019 - 12:19 MST
Identified
The phone provider for Canvas Support is currently experiencing technical problems. Due to this fact reaching Canvas Support via phone may take longer than normal. You are still able to contact Canvas Support via our chat tool, email, and the help menu.
Posted Dec 19, 2019 - 11:29 MST