To view uptime history for your instance of Canvas, click here.

We are experiencing degraded performance with our ticketing system
Incident Report for Instructure
Resolved
Our service provider has resolved the issue that was causing the degraded performance. We apologize for any inconvenience this may have caused.
Posted May 17, 2017 - 00:37 MDT
Investigating
We are experiencing degraded performance with our ticketing system due to an issue with our service provider. Some users may experience issues when trying to contact Canvas support through the webform/email contact methods. Our service provider is aware, and actively working to resolve these issues. We apologize for any inconvenience this may cause.
Posted May 16, 2017 - 23:58 MDT