To view uptime history for your instance of Canvas, click here.

Slow load times or error messages when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 08, 2020 - 04:56 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2020 - 04:44 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 08, 2020 - 04:42 MDT
Investigating
We are currently looking into an issue where users are running into error messages or slow load times when accessing Canvas.
Posted Jul 08, 2020 - 04:27 MDT
This incident affected: Canvas (Canvas).