To view uptime history for your instance of Canvas, click here.

Some users hosted in the North Virginia region may be experiencing slowness or errors when accessing New Quizzes in Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 09:33 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2021 - 09:22 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 23, 2021 - 09:11 MDT