To view uptime history for your instance of Canvas, click here.

Aug. 4th Canvas Slowness
Incident Report for Instructure
Resolved
Our engineering team has addressed the behavior. The long loading time and errors should now be resolved.
Posted Aug 04, 2021 - 20:06 MDT
Monitoring
Users may be encountering long load times when accessing Canvas. Our engineering team is aware and working to resolve it as soon as possible. We will give an update when the issue is resolved.
Posted Aug 04, 2021 - 19:01 MDT
This incident affected: Canvas (Canvas LMS).