To view uptime history for your instance of Canvas, click here.

A small amount of users are experiencing long load times or error messages when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 07:46 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2020 - 07:37 MDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2020 - 07:34 MDT
This incident affected: Canvas (Canvas).