To view uptime history for your instance of Canvas, click here.

Canvas page errors
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 10:03 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2022 - 09:57 MDT
Investigating
Users are experiencing issues page errors and slowness when accessing canvas. We will update this status as we have additional information.
Posted Sep 13, 2022 - 09:56 MDT
This incident affected: Instructure.