To view uptime history for your instance of Canvas, click here.

Some users experiencing page time outs while trying to access Canvas
Incident Report for Instructure
Resolved
Our DevOps team was able to locate the cause of this behavior and implement a solution. Again, we apologize for any inconvenience this may have caused your users.
Posted Jan 08, 2018 - 10:41 MST
Identified
Some users are experiencing intermittent access when trying to load pages within Canvas resulting in page errors being displayed. Our DevOps team has identified the issue, and is currently working to deploy a fix. We apologize for any inconvenience this has caused.
Posted Jan 08, 2018 - 08:33 MST