To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
Canvas has resumed normal operations. We apologize for the inconvenience, and appreciate your patience.
Posted Oct 21, 2019 - 12:33 MDT
Monitoring
Load time appear to have improved. We will continue to monitor the situation.
Posted Oct 21, 2019 - 12:17 MDT
Update
We are continuing to investigate the cause of the long load times when accessing Canvas. As we find more information will continue to update.
Posted Oct 21, 2019 - 11:31 MDT
Investigating
Some Canvas users are sporadically experiencing longer loading times when accessing Canvas. Our Devops team has been made aware and are currently investigating this behavior. We'll be posting an additional update shortly.
Posted Oct 21, 2019 - 11:15 MDT
This incident affected: Canvas (Canvas LMS).