To view uptime history for your instance of Canvas, click here.

Certain ISP's are having difficulty accessing Canvas
Incident Report for Instructure
Resolved
Connections to Canvas seem to be normalizing. Thank you for your patience while this situation was occurring.
Posted Mar 02, 2018 - 15:49 MST
Monitoring
Users that are trying to access Canvas while using certain providers, such as, but not limited to Spectrum, and Comcast are reporting trouble accessing pages and portals. This appears to be related to outages with these individual ISP's. We sincerely apologize for any inconvenience this may be causing and appreciate your patience.
Posted Mar 02, 2018 - 13:13 MST