To view uptime history for your instance of Canvas, click here.

Notifications may be delayed for some user in Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 20:25 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2020 - 17:04 MDT
Investigating
Due to an increased backlog, some Canvas notifications may take longer to process and send than normal. This is impacting SMS, Push-notifications, and emails. We're seeing improvements on the delayed responses, and we'll continue to monitor for any further increases in wait times.
Posted Sep 24, 2020 - 16:24 MDT