To view uptime history for your instance of Canvas, click here.

Some users are experiencing page errors when accessing Canvas
Incident Report for Instructure
Resolved
We have seen a decrease in reports of affected users, and that the impact this issue has on users is minimal. If the issue persists, we recommend following normal troubleshooting procedures.
Posted Oct 24, 2019 - 11:01 MDT
Monitoring
A small number of users are running into page errors when trying to access Canvas. This is the result of a DNS issue from Amazon Web Services (AWS). https://status.aws.amazon.com/

Although this has since been resolved, some users using specific Internet Service Providers (ISP's) may still be impacted. If you're continuing to see the behavior, resetting the network connection may help remedy the errors. We will monitor the situation and post further updates as they become available.
Posted Oct 23, 2019 - 10:18 MDT