To view uptime history for your instance of Canvas, click here.

Some users experiencing page errors while trying to access Canvas
Incident Report for Instructure
Resolved
A small percentage of Canvas users in the U.S. were experiencing page errors within Canvas. Our DevOps team has ensured the site is available and running normally now. We apologize for any trouble you've experienced.
Posted Mar 12, 2018 - 21:14 MDT
Identified
A fix has been implemented and we are monitoring the results. We apologize for any trouble you've experienced.
Posted Mar 12, 2018 - 21:13 MDT
Investigating
Some users are experiencing intermittent access when trying to load pages within Canvas resulting in page errors being displayed. Our DevOps team is aware of the issue and working to deploy a solution. We apologize for any inconvenience this has caused.
Posted Mar 12, 2018 - 21:11 MDT