To view uptime history for your instance of Canvas, click here.

Notifications may be delayed for some users.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 16:42 MDT
Monitoring
Due to an increased backlog, some Canvas notifications may take longer to process and send than normal. This is impacting SMS, Push-notifications, and emails. We're seeing improvements on the delayed responses, and we'll continue to monitor for any further increases in wait times.

Thank you for your patience.
Posted Mar 23, 2020 - 15:42 MDT