To view uptime history for your instance of Canvas, click here.

Some users are experiencing long load times while accessing Canvas
Incident Report for Instructure
Resolved
Canvas load times are now returning back to expected performance levels. We appreciate your patience, and sincerely apologize for any inconvenience this may have caused you.
Posted Mar 11, 2019 - 09:35 MDT
Investigating
A small number of Canvas users are experiencing page slowness when accessing their courses. Our engineers are aware of the increase in load times, and are currently working to mitigate the behavior. We'll post another update when we have further details. Thank you for your patience.
Posted Mar 11, 2019 - 09:23 MDT
This incident affected: Canvas (Canvas LMS).