To view uptime history for your instance of Canvas, click here.

Some users in the US region are unable to access Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 01, 2018 - 09:43 MDT
Investigating
Some users in the US region were unable to access Canvas from 9:25am until 9:42am MST. We apologize for any inconvenience this downtime may have caused.
Posted Jun 01, 2018 - 09:38 MDT
This incident affected: Canvas (Canvas LMS).