To view uptime history for your instance of Canvas, click here.

A small percentage of Canvas users in the U.S. are seeing slow load times in Canvas.
Incident Report for Instructure
Resolved
A small percentage of Canvas users in the U.S. were seeing slow load times. Our DevOps team has ensured the site is available and running normally now. We apologize for any trouble you've experienced.
Posted Dec 04, 2017 - 13:56 MST
Update
We are monitoring activity on this issue. It appears this issue is intermittent. We will continue to monitor this and update when it has been resolved. We apologize for the inconvenience and thank you for your patience.
Posted Dec 04, 2017 - 11:10 MST
Monitoring
A small percentage of Canvas users in the U.S. are seeing slow load times in Canvas. A fix has been implemented and we are monitoring the results. We apologize for any trouble you've experienced.
Posted Dec 04, 2017 - 08:41 MST