To view uptime history for your instance of Canvas, click here.

Users in the US may be experiencing slow page load times
Incident Report for Instructure
Resolved
Our DevOps team have identified the issue and deployed a fix that has resolved the slowness being experienced by users.
Posted Aug 16, 2018 - 08:35 MDT
Investigating
Some users in the US may be experiencing slow page load times. Our DevOps team is aware of the issue. We apologize for any inconvenience caused.
Posted Aug 16, 2018 - 07:47 MDT