To view uptime history for your instance of Canvas, click here.

Some Canvas users in the US experiencing slow load times
Incident Report for Instructure
Resolved
Resolved - some users in the US experienced slow load times when accessing Canvas. Our DevOps team identified and resolved the page load times for affected users. We apologize for any inconvenience.
Posted Mar 26, 2018 - 09:31 MDT
Investigating
We are aware of slow load times affecting a small portion of users in the US users. We apologize for the disruption to service and our Devops team are working on resolving the page load times.
Posted Mar 26, 2018 - 08:45 MDT