To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing longer load times or page timeouts when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 13, 2020 - 09:18 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2020 - 09:12 MDT
Investigating
We are currently investigating this issue.
Posted Oct 13, 2020 - 09:09 MDT
This incident affected: Canvas (Canvas).